Install Windows 7 (boot) 64-bit to RAID array 3TB on Gigabyte Hybrid EFI motherboard

Last Modified: Thu, 29 Aug 2013 20:07:41 +0000 ; Created: Thu, 29 Aug 2013 20:05:09 +0000

Short Answer: You can't. Not with a RAID array with more than 2.2TB of a single volume disk. The FakeRAID on the Gigabyte motherboard with Hybrid EFI does not have a ROM that supports booting from a volume larger than 2.2TB in EFI mode. This means you can't install Windows 7 (or later) 64-bit onto a RAID array.

If you want a > 2.2TB disk for OS boot you'll have to use a non-RAID mode or possibly an add-on controller if you can find one.

For storage-only (not boot or OS install) you can have disks greater than 2.2TB.

I tried multiple tricks. At one point I got a USB disk to boot in EFI mode and start the install after I used diskpart to manually partition a GPT volume of 4TB RAID. Windows did the extracting files, but it failed to make the disk bootable. I just got error messages about how setup failed.

I contacted Gigabyte support who verified that using RAID will not work as the Hybrid EFI and RAID ROM didn't support bootable volumes larger than 2.2TB. Disappointing as my motherboard is only from 2011 and has no BIOS update to full UEFI.

My take-away is Hybrid EFI is not as good as full UEFI if you are dealing with larger volumes. Also of note is that Gigabyte's FakeRAID in RAID10 mode only supports 4 drives even though RAID10 isn't the restriction for this only the RAID controller implementation. Maybe I'll find an add-on RAID card that can boot EFI with volumes >2.2TB or perhaps I'll just get a SSD for my OS.

My setup:

  • Gigabyte GA-970A-UD3
    • Revision 1.0
    • Hybrid EFI
    • (Of note is that the rev3.0 has full UEFI BIOS, no update for prior rev.)
  • Two 2TB Seagate SATA 6.0gbps drives
  • RAID0 (STRIPE) setup for 4TB volume

My original support inquiry with Gigabyte and their response:

From : Rodney
Sent : 8/29/2013 23:43
Question : I have two 2TB SATA drives in a RAID0 (stripe) array for a single 4TB.

I am unable to install Windows 7 64-bit Professional Edition onto this single 4TB drive.

I set "EFI CD/DVD Boot Option" to "EFI"

My SATA option is RAID.

I have the F7 BIOS (latest stable, non-beta).

I begin by booting from the USB DVD with Windows 7 64-bit installer. I arrive at the screen to select which disk to install to. As expected the 4TB RAID array does not appear. I choose to install driver and use the "AMD SATA RAID Driver (Preinstall driver, press F6 during Windows* setup to read from floppy)" -- version -- "3.3.1540.33, 2012/10/25"

I can now see the 4TB (shows as 3700GB) drive. I select the drive and click on Install.

I get an error from Windows that it cannot install to the selected drive. "Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk." I also attempted using a Windows 7 USB install drive (FAT32 formatted), but that gave me the same error.

How do I install Windows 7 64-bit Professional Edition to a 4TB disk?

Model Name : GA-970A-UD3(rev. 1.0/1.1)
M/B Rev : 1.0
BIOS Ver : F7
Serial No. : [removed]
Purchase Dealer :
VGA Brand : Nvidia Model : GT 430
CPU Brand : AMD Model : Phenom II X4 970 Speed : 3.5GHz
Operation System : Win 7 64-bit SP : 1
Memory Brand : Corsair Type : DDR3
Memory Size : 8GB Speed : PC3-12800
Power Supply : 600 W


Answer : Dear Customer,

Due to the raid rom limitation the OS cannot exceed 2.2TB, please use the raid as the storage or you will need to use an single drive as the OS.